Mailinglist Archive: opensuse-buildservice (65 mails)

< Previous Next >
[opensuse-buildservice] Problem with GPG verification: nothing provides gpg-offline
Currently the package "maildrop" from server:mail repository fails to
build for many distributions, e.g. for Tumbleweed, Leap 42.3, Leap 15.0
and Factory.

https://build.opensuse.org/package/show/server:mail/maildrop

The error message is "nothing provides gpg-offline".

The maildrop.spec file contains the following GPG related entries:

%if 0%{?suse_version} >= 1230
BuildRequires:  gpg-offline
%endif

[...]

%prep
%if 0%{?suse_version} >= 1230
%gpg_verify %{SOURCE1}
%endif

The macro %gpg_verify is unavailable (tested with Tumbleweed).

What is currently the right way to verify GPG signatures of sources?
What is a good example package for GPG verification?

Greetings,
Björn
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation