Mailinglist Archive: opensuse-buildservice (80 mails)

< Previous Next >
Re: [opensuse-buildservice] Unable to BR gcc7 from SLE_12_SP3?
On Wed, Aug 22, 2018 at 8:33 AM Adrian Schröter <adrian@xxxxxxx> wrote:

On Mittwoch, 22. August 2018, 12:33:32 CEST wrote Neal Gompa:
Hey,

I'm trying to build a package in my private OBS instance using gcc7 on
SLE 12 SP3 and openSUSE Leap 42.3. It is able to resolve the
dependency for openSUSE Leap 42.3, but fails with SLE 12 SP3.

I get the following error from OBS:

nothing provides gcc7
nothing provides gcc7-c++

However, I see it listed in SLE 12 SP3:
https://build.opensuse.org/package/show/SUSE:SLE-12-SP3:GA/gcc7

My meta snippet is set to the following:

<repository name="SLE_12_SP3">
<path project="openSUSE.org:SUSE:SLE-12-SP3:GA" repository="standard"/>
<arch>x86_64</arch>
</repository>

What am I doing wrong?

gcc7 was only introduce via maintenance update, so you need to build against

<path project="openSUSE.org:SUSE:SLE-12-SP3:Update" repository="standard"/>


So I added that and now I get this:

nothing provides libatomic1 >= 7.3.1+r258812-5.2 needed by gcc7
nothing provides libcilkrts5 >= 7.3.1+r258812-5.2 needed by gcc7
nothing provides libgcc_s1 >= 7.3.1+r258812-5.2 needed by gcc7
nothing provides libgomp1 >= 7.3.1+r258812-5.2 needed by gcc7
nothing provides libitm1 >= 7.3.1+r258812-5.2 needed by gcc7
nothing provides liblsan0 >= 7.3.1+r258812-5.2 needed by gcc7
nothing provides libmpx2 >= 7.3.1+r258812-5.2 needed by gcc7
nothing provides libmpxwrappers2 >= 7.3.1+r258812-5.2 needed by gcc7
nothing provides libtsan0 >= 7.3.1+r258812-5.2 needed by gcc7
nothing provides libubsan0 >= 7.3.1+r258812-5.2 needed by gcc7

I'm really confused. :'(

--
真実はいつも一つ!/ Always, there's only one truth!
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups