Mailinglist Archive: opensuse-buildservice (54 mails)

< Previous Next >
Re: [opensuse-buildservice] AppImage build with old g++ fails
  • From: Frank Kunz <mailinglists@xxxxxxxxxxxxxxxxx>
  • Date: Tue, 24 Oct 2017 19:56:04 +0200
  • Message-id: <5511223.rNn9ZfBRyZ@donald>
Am Dienstag, 24. Oktober 2017, 09:53:22 CEST schrieb Adrian Schröter:
On Montag, 23. Oktober 2017, 22:46:12 CEST wrote Frank Kunz:
Hello,

I'm trying to build an AppImage (https://build.opensuse.org/package/show/
home:frank_kunz/horizon). The sources are compiled with '-std=c++14'. The
g++ compiler that is used for build the AppImage is

g++ (SUSE Linux) 4.8.5

It seems that this compiler cannot handle the command line option:

[ 66s] g++: error: unrecognized command line option '-std=c++14'
[ 66s] Makefile:419: recipe for target 'util/uuid.o' failed

I tried rpm build that is using a newer compiler (7.2.1), and that works.

How to get a newer compiler version into use for AppImage build?

try to use gcc6-c++ as build requires here...

That is working. But I'm still struggling with a problem to get the appimage
package for cppzmq-devel that I use already in rpm build. How can I find out
which packages are available for appimage builds?

Br,
Frank


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >