Mailinglist Archive: opensuse-buildservice (119 mails)

< Previous Next >
Re: [opensuse-buildservice] Update CentOS:CentOS-7 to latest SP
  • From: Mathias Homann <Mathias.Homann@xxxxxxxxxxxx>
  • Date: Tue, 24 May 2016 11:14:36 +0200
  • Message-id: <1921212.LqVO47MIvx@kumiko>
Am Dienstag, 24. Mai 2016, 11:06:58 schrieb Jan Engelhardt:
On Tuesday 2016-05-24 11:00, Mathias Homann wrote:
Am Dienstag, 24. Mai 2016, 10:45:13 schrieb Jan Engelhardt:
RH/CentOS 7 shipped a libical and libical-devel rpm of version 0.42,
and libical.so.0. Packages built against this are unable to get
installed on RH 7.2, because that is using libical-1.x and libical.so.1.
Please consider updating the CentOS:CentOS-7 import to reflect the later
service pack.

...at least when it comes to RHEL7 that should not happen! Clear violation
of the ABI/API backwards compatibility that they are so proud of!

Can you provide me with proof (logfiles etc) so that I can open a bug with
RH?
Just look at the HTTP directories / the ISOs...

http://vault.centos.org/7.0.1406/os/x86_64/Packages/libical-0.48-6.el7.x86_6
4.rpm (said directory has no libical-1)

vs.
http://mirror2.hs-esslingen.de/centos/7.2.1511/os/x86_64/Packages/libical-1.
0.1-1.el7.x86_64.rpm (said directory has no fallback libical-0 either)

... I was talking about RHEL, not CentOS...

In RED HAT ENTERPRISE this should not happen. No idea what CentOS says about
backwards compatibility...

Cheers
MH
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >