Mailinglist Archive: opensuse-buildservice (119 mails)

< Previous Next >
Re: [opensuse-buildservice] Private OBS -- almost there...

Em [DATE], "[NAME]" <[ADDRESS]> escreveu:

On Dienstag, 17. Mai 2016, 19:33:46 wrote Erico Mendonca:
Hello all,

I managed to get (almost) everything in OBS running. I have several VMS
acting as workers for i586 and x86_64, and one 16-core machine running as a
KVM worker. However, my s390x zLinux worker is acting strange: it tries to
download x86_64 RPMs for its chroot instead of the s390x ones which are
available from the same repository.

maybe your repo is configured to use qemu emulated builds?

Any "Target: " line in your prjconf ? Or the repo you build against?

In doubt, send me the the output of

osc buildinfo ...
osc buildconfig ...

That definitely helped me finding the problem! The buildinfo was showing me
that it couldn’t find some dependencies (whereas the UI didn’t). In fact, the
SDK packages for s390x were missing in the DoD repository. Copied them and ran
createrepo, everything works now. And the Arch Filter must be set to “s390x”.
That’s all.

On a related note, I was not succeeding at creating a repository for SLE12SP1.
I checked and re-checked the RPMs and the repository definitions multiple
times, and everything appeared to be fine. It wouldn’t show up as a valid build
target at all. Today I noticed that the project config (which was cloned from
the SUSE:SLE-11-SP1:GA project at was WAY smaller than the one
from SUSE:SLE-11:GA project. I imported the project config from SUSE:SLE-11:GA
and it worked flawlessly.

Is the project config from SUSE:SLE-11-SP1:GA corrupted or am I missing

— Erico Mendonça

Dedicated Support Engineer
< Previous Next >
Follow Ups