Mailinglist Archive: opensuse-buildservice (138 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: CentOS-6.0: have choice for java-devel
  • From: Nico Kruber <nico.kruber@xxxxxxxxx>
  • Date: Mon, 29 Feb 2016 10:27:05 +0100
  • Message-id: <1571153.4BRHluLHho@nico-pc>
On Friday, 26 February 2016 15:16:36 CET Nico Kruber wrote:
On Monday 22 Feb 2016 18:22:48 Matwey V. Kornilov wrote:
2016-02-22 18:21 GMT+03:00 Adrian Schröter <adrian@xxxxxxx>:
On Montag, 22. Februar 2016, 15:54:26 CET wrote Matwey V. Kornilov:
22.02.2016 13:56, Adrian Schröter пишет:
On Montag, 22. Februar 2016, 11:16:53 CET wrote Matwey V. Kornilov:
2016-02-22 10:40 GMT+03:00 Adrian Schröter <adrian@xxxxxxx>:
On Freitag, 19. Februar 2016, 22:22:39 CET wrote Matwey V.
Kornilov:
Hello,

Project CentOS:CentOS-6 probably needs additional Prefer in
project
configuration.
Now I see "have choice for java-devel >= 1.5 needed by ant".

Can you tell me your project/package where I can see this?

https://build.opensuse.org/package/show/home:matwey:impala/impala

k, it seems openjdk 1.8.0 is now the default ... adapted that.

Hm, It is still unresolved.

it is just the server load most likely ...

you can verify such things using "osc buildinfo"

Thank you.

let me note, however, that there is a bug in the currently available CentOS6
version that breaks the use of ant with openjdk 1.8.0 !

https://build.opensuse.org/package/live_build_log/home:scalaris:svn/scalaris
-svn-examples-wiki/CentOS_6/x86_64

As long as the updated packages (which should be available in the official
update repos!) are not installed, we cannot build anything with ant. See
https://bugzilla.redhat.com/show_bug.cgi?id=1149605

If I recall correctly, this was working a while ago, but I don't remember
which java jdk was installed then - the bug apparently only affects JDK8
(not JDK7)


Regards
Nico

ok, using java-1.7.0-openjdk-devel (instead of java-1.8.0-openjdk-devel which
was set as the default a week ago) allows builds with ant again.

@Adrian: can you prefer java-1.7.0-openjdk-devel instead of 1.8.0 in the
global config (or update CentOS) so this will work globally (again)?


Thanks
Nico
< Previous Next >
Follow Ups