Mailinglist Archive: opensuse-buildservice (126 mails)

< Previous Next >
[opensuse-buildservice] osc api /build/project/repository/arch/package/binaryname?view=fileinfo_ext error
Hi,

Since I updated "perl-BSSolv" to 0.20.0 for my local opensuse 12.1 OBS server,
I started to see errors for some packages (not all packages)
while viewing the page for the "Detailed Information About xxxxxx.rpm" on the
browser.

I have narrowed it down that it can be reproduced through "osc api" command:
$ osc api -X GET
/build/home:rickliu:test/openSUSE_13.1/i586/osc/osc-0.132.6.bcm3-2.1.noarch.rpm?view=fileinfo_ext
Server returned an error: HTTP Error 400: excess hash entries obsoletes
excess hash entries: obsoletes

However,
if I run with "view=fileinfo" instead of "view=fileinfo_ext",
then it's ok:
$ osc api -X GET
/build/home:rickliu:test/openSUSE_13.1/i586/osc/osc-0.132.6.bcm3-2.1.noarch.rpm?view=fileinfo
<fileinfo filename="osc-0.132.6.bcm3-2.1.noarch.rpm">
<name>osc</name>
<version>0.132.6.bcm3</version>
<release>2.1</release>
<arch>noarch</arch>
<source>osc</source>
<summary>openSUSE Build Service Commander</summary>
<description>Commandline client for the openSUSE Build Service.

See http://en.opensuse.org/openSUSE:OSC , as well as
http://en.opensuse.org/openSUSE:Build_Service_Tutorial for a general
introduction.</description>
<size>340139</size>
<mtime>1420058920</mtime>
<provides>config(osc) = 0.132.6.bcm3-2.1</provides>
<provides>osc = 0.132.6.bcm3-2.1</provides>
<requires>config(osc) = 0.132.6.bcm3-2.1</requires>
<requires>python(abi) = 2.7</requires>
<requires>python-m2crypto &gt; 0.19</requires>
<requires>python-urlgrabber</requires>
<requires>python-xml</requires>
<requires>rpm-python</requires>
</fileinfo>


Could this be caused by the upgrade of "perl-BSSolv"?
or it's some other issues?

How do I debug/fix this problem?


Rick
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups