Mailinglist Archive: opensuse-buildservice (105 mails)

< Previous Next >
[opensuse-buildservice] How to debug "unresolveable" messages?
  • From: Eric MSP Veith <eveith@xxxxxxxxxxxxxxxxx>
  • Date: Sat, 25 Oct 2014 23:02:53 +0200
  • Message-id: <2433053.DEJa9IdX9M@basileia>
Dear list,

in my private OBS instance, there's a project that uses the following
repository config:

<repository name="openSUSE_13.1">
<path project="" repository="standard"/>
<path project="" repository="openSUSE_13.1"/>
<path project="" repository="openSUSE_13.1"/>
<path project=""

One spec file features these BuildRequires:

BuildRequires: gcc-c++, make
BuildRequires: libqt5-qtbase-devel
BuildRequires: libgdal-devel, libgeos-devel, libproj-devel
BuildRequires: boost-devel >= 1.56.0, liblog4cxx-devel

Now, when trying to build the packages, I get:

unresolvable: nothing provides boost-devel >= 1.56.0, nothing provides
libQt5Sql5 = 5.3.2 needed by libQt5Sql5-sqlite

But libQt5Sql5 is part of KDE:Qt53, even in the given version. I added the
repository to my local machine's zypper config and ran "zypper se 'libQt5Sql5
= 5.3.2', and it found the package! Same with "boost-devel >= 1.56.0".
"liblog4cxx", which also comes from "", is
*not* listed as unresolveable.

I'd like to debug these messages, but I'm unsure on where to start. How can I
debug the dependency chain?

Thanks alot in advance for any hint.

--- Eric
< Previous Next >