Mailinglist Archive: opensuse-buildservice (45 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS 2.5 / openSUSE 13.1 / KVM Worker - could not find /dev/sda
  • From: Matthew Drobnak <mdrobnak@xxxxxxxxxxxx>
  • Date: Mon, 8 Sep 2014 16:25:54 +0000
  • Message-id: <1410193554.4907.1.camel@mdrobnak-MacBookAir>
You found the right reason, but I didn't understand why it worked

I had not rebooted at some point..and I should have. The code in

if grep ^flags /proc/cpuinfo | egrep -q " (svm|
vmx) " && modprobe kvm; then
echo "Found KVM virtualization"
# support virtio
# FIXME: find a better way to do this
without getting removed by kiwi again.
if ! grep -q
"^INITRD_MODULES=.*virtio_pci virtio_blk" /etc/sysconfig/kernel; then
sed -i 's,^INITRD_MODULES="\(.*
\)",INITRD_MODULES="\1 loop dm-mod dm-snapshot binfmt-misc fuse kqemu
squashfs ext2 ext3 ext4 reiserfs nf_conntrack_ipv6 binfmt_misc
virtio_pci virtio_blk fat vfat nls_cp437
nls_iso8859-1",' /etc/sysconfig/kernel
mkinitrd || unset RUN_VIRT

Shows that is why it auto-fixes itself.

It's now working fine.


On Thu, 2014-09-04 at 22:02 +0200, Togan Muftuoglu wrote:
"Matthew" == Matthew Drobnak <mdrobnak@xxxxxxxxxxxx> writes:
Not that I run private OBS but I use osc locally to build with kvm and I had a
similar issue.

Matthew> Here's the full log output:
Matthew> [ 5s] /usr/bin/qemu-kvm -no-reboot -nographic -vga none -net
Matthew> -cpu host -kernel /boot/vmlinuz -initrd /boot/initrd -append

I solved that by creating a initrd-virtio and the problem was solved but I am
not sure if that would help your case as well

Life is endless possibilities

< Previous Next >