Mailinglist Archive: opensuse-buildservice (116 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS Appliance stilll stall doing build
On Mittwoch, 30. Juli 2014, 10:09:29 wrote Adrian Schröter:
On Mittwoch, 30. Juli 2014, 10:03:07 wrote Lars Nielsen:
Hello I still have a problem with our OBS Appliance.
But I have come a little further. I now know that if I try this:

/usr/bin/qemu-kvm -no-reboot -nographic -vga none -net none -cpu host
-kernel /boot/vmlinuz -initrd /boot/initrd -append root=/dev/sda panic=1
quiet no-kvmclock nmi_watchdog=0 rw rd.driver.pre=binfmt_misc elevator=noop
console=ttyS0 init=/.build/build -m 256 -drive
file=/var/cache/obs/worker/root_8/root,if=none,id=disk,serial=0,cache=unsafe
-device ide-hd,drive=disk -drive
file=/var/cache/obs/worker/root_8.swap,if=none,id=swap,serial=1,cache=unsafe
-device ide-hd,drive=swap -smp 1


...



Can anyone help me on from this point because this is actually the only
blockade for me now (I hope).

So, the block device does not appear. You may use a initrd which has not
the proper kernel modules for kvm?

There was a misconfiguration of our OBS-Appliance build for OBS 2.5. Please
download the version 2.5.4-Build2.2 to get this fixed.

This includes also obs-server-2.5.4.2 which is fixing the initrd generation
on first boot.

sorry for that
adrian

--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE LINUX GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 21284
(AG Nürnberg)
Maxfeldstraße 5
90409 Nürnberg
Germany



< Previous Next >
List Navigation
This Thread
  • No further messages