Mailinglist Archive: opensuse-buildservice (111 mails)

< Previous Next >
[opensuse-buildservice] About permission denined /usr/lib and /usr/include
I have tried to get an answer on the IRC, but no luck on a solution.
I need to create packages for a client, which places header files in
/usr/include or /usr/local/lib and .a files in /usr/lib or /usr/local/lib
My problem is, when I uploaded to build.opensuse.org, and tries to build I get
an permission denined, do to the fact i runs in CHROOT (which of course makes
sense).
I was then told to add %{buildroot} to the path /usr/lib.
But still no luck. Here is where I encounter the problem first in the spec
file:

%setup
if [ ! -d %{buildroot}"/usr/local/lib/secret/"%{name}"_"%{version} ] && [ ! -d
%{buildroot}"/usr/local/include/secret/"%{name}"_"%{version} ]; then
mkdir %{buildroot}/usr/local/lib/secret/%{name}_%{version}
mkdir %{buildroot}/usr/local/include/secret/%{name}_%{version}
echo %{name} " version: " %{version} "has been installed in the secret
library"

else
echo This version of ninja is already installed
fi

and later in install when I try to move my files there
˘
can anyone give me at least an idea on how to fix this ?


Med venlig hilsen / Best regards

Lars Nielsen
Student programmer
Email: lars@xxxxxxxxxx



--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >