Mailinglist Archive: opensuse-buildservice (233 mails)

< Previous Next >
Re: [opensuse-buildservice] Handling BuildRequires: Package = 1.2.3
??n Monday 2013-11-18 22:46, Matthew Drobnak wrote:

I'm running 2.3 in a private install.

I seem to be hitting into this bug:

I have python2.7-numpy-1.6.2, python2.7-numpy-1.7.1,
python2.7-pandas-0.9.1, and python2.7-pandas-0.11.

The following is what needs to happen:

Pandas 0.9.1 build and runtime requires NumPy 1.6.2
Pandas 0.11 build and runtime requires NumPy 1.7.1

I cannot seem to get OBS to find numpy 1.6.2. It keeps saying
unresolvable. I've even moved 1.7.1 to another project, but somehow it
still gets installed into the build VM.

So two things:

Why does OBS behave like this for BuildRequires? Why does it stop on
first match?

It would seem that is the way how it was written. A name (such as
python2.7-numpy-devel) maps to at most one .rpm file, which also
hides any inherited packages (from <repository>) of any version.


BuildRequires: python2.7-numpy-devel = 1.6.2
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References