Mailinglist Archive: opensuse-buildservice (145 mails)

< Previous Next >
Re: [opensuse-buildservice] I suspect that my chromium package build is going wrong
Why you do not base your package on our chromium package?

I am totally new to this and since I've got lucky to get the build
process going quickly, I have "cheated" and skipped the "dive deeper
into the docs" part. So I don't know how would I do this and if there
are any benefits of doing it. First glance tells me (and please
correct me if I'm making a wrong assumption) that openSUSE:Factory is
a project that builds packages for OpenSUSE and network:chromium is a
project for building Linux binaries that are distribution agnostic. My
project is making use of the vanilla source code chromium tarball +
Debian patches and is trying to build a package for the 32bit Debian
Wheezy - same version of chromium as the one in the repository, the
only difference between it and the chromium package from the Debian
repository being that I'm trying to also compile chromedriver and
bundle it into the package.

Should I be concerned about the perpetuum mobile I've accidentally
started? Since I'm not getting the final debian package it looks like
my project is just eating up free resources for nothing. What should I
do next? Just cancel the build manually?

2013/10/1 Marcus Meissner <meissner@xxxxxxx>:
On Tue, Oct 01, 2013 at 02:21:26PM +0300, James Bond wrote:
This is the package I'm trying to build

Build process worked for almost 10 hours, the last message I saw in
the build log was the one related to the linking of the chromium
binary I think (that's when I've got out of memory error when trying
to build locally, so that's the reason why I've tried to build using
the build service). After that the timestamps in the build log
suddenly started over and judging by the content of the log, the build
process started from the beginning again. I've got no package. The
build is shown as still going.

Could somebody have a look and tell me what's going on, please?


PS: I am trying to rebuild chromium because of a few reasons:

- the official 32bit chromedriver binary for linux doesn't work on
debian wheezy because it's compiled against a newer version of glibc
- there's a chromium debian package, but there's no package for chromedriver
- source code of chromedriver is part of chromium source code tree

At this moment it looks like the build process is running for the
third time already.

It likely ran out of memory or diskspace.

Why you do not base your package on our chromium package?

openSUSE:Factory chromium
network:chromium chromium

Ciao, Marcus
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation