Mailinglist Archive: opensuse-buildservice (148 mails)

< Previous Next >
Re: [opensuse-buildservice] obs worker and qemu-linux-user package
  • From: Guillaume Gardet <guillaume.gardet@xxxxxxx>
  • Date: Tue, 10 Sep 2013 09:49:49 +0200
  • Message-id: <522ECF1D.2080704@free.fr>

Le 10/09/2013 09:14, Adrian Schröter a écrit :
Am Montag, 9. September 2013, 14:01:03 schrieb Guillaume Gardet:
Le 09/09/2013 13:55, Adrian Schröter a écrit :
Am Montag, 9. September 2013, 13:49:22 schrieb Guillaume Gardet:
Le 09/09/2013 13:45, Adrian Schröter a écrit :
Am Montag, 9. September 2013, 13:41:52 schrieb Guillaume Gardet:
Hi,

on a private OBS instance building armv6 packages, obs-worker machines
need
to have qemu-linux-user package installed.

I think it is a bug, since qemu-linux-user package should be downloaded
and
installed with all other packages during pre-install.
yes, with the right config this should happen.

If you build against openSUSE.org factory qemu projects, this should
happen
definitily
It is against openSUSE:Factory:ARM for _armv6l_ arch. I can see
qemu-linux-user in the log but when going to chroot, it fails (wrong
format) if qemu-linux-user is not installed.
building against a qemu* repository?

The "standard" repository is configured for arm hardware build.
No standard.

According to Factory:ARM project config, it is a qemu build, even for
standard repo: %ifarch aarch64 armv6l armv6hl
%define qemu_user_space_build 1
%endif
k, I see this has been configured differently meanwhile.

You said you are using chroot builds, right?

Yes.

I suppose you are using the stable OBS 2.4.x ?

Yes.

Can you try to install the build* packages from OBS:Server:Unstable project
on your server? IIRC I made some fixes in that area some month ago.

Will try it, but probably not before next week.

Guillaume

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >