Mailinglist Archive: opensuse-buildservice (247 mails)

< Previous Next >
Re: [opensuse-buildservice] false unresolvable in OBS
On Fri, Jun 28, 2013 at 04:30:34PM +0200, Stanislav Brabec wrote:
I need to add conflict to util-linux to conflict with an old version of
coreutils (there is a file conflict of su and kill):
Conflicts: coreutils < 8.21-4

Factory has
coreutils-8.21-4.2

Base:System has
coreutils-8.21-205.1

So it should be OK, and there should be no conflict.

No, conflicts are checked against the provides, and:

$ rpm -qp --provides coreutils.rpm
coreutils = 8.21
coreutils = 8.21-4.2
coreutils(x86-64) = 8.21-4.2
fileutils = 8.21
libstdbuf.so()(64bit)
mktemp = 8.21
sh-utils = 8.21
stat = 8.21
textutils = 8.21

(That's why you should never provide versions without releases.)

Sigh,
Michael.

--
Michael Schroeder mls@xxxxxxx
SUSE LINUX Products GmbH, GF Jeff Hawn, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
References