Mailinglist Archive: opensuse-buildservice (67 mails)

< Previous Next >
[opensuse-buildservice] inexplicable choice for symbol dependency resolution
  • From: Adam Spiers <aspiers@xxxxxxxx>
  • Date: Thu, 6 Dec 2012 20:17:32 +0000
  • Message-id: <20121206201732.GC25772@pacific.linksys.moosehall>
In systemsmanagement:crowbar:2.0, all the crowbar-barclamp-* packages
are currently showing unresolvable due to an error like:

have choice for rubygem(1.9.1:mail:2.4) >= 2.4.4 needed by
rubygem-actionmailer-3_2: rubygem-mail-2_4 rubygem-mail

e.g.


https://build.opensuse.org/project/monitor?blocked=0&building=0&dispatching=0&finished=0&pkgname=crowbar-barclamp-crowbar&project=systemsmanagement%3Acrowbar%3A2.0&scheduled=0&signing=0&succeeded=0

but I have no idea why it thinks it can get rubygem(1.9.1:mail:2.4)
from *anywhere*, let alone two different places, since rubygem-mail in
openSUSE:Factory doesn't provide it:


https://build.opensuse.org/package/binary?arch=x86_64&filename=rubygem-mail-2.5.2-1.1.x86_64.rpm&package=rubygem-mail&project=openSUSE%3AFactory&repository=standard

and I disabled builds for rubygem-mail-2_4 in sm:c:2.0 and also wiped any
previously built binaries:


https://build.opensuse.org/package/binaries?package=rubygem-mail-2_4&project=systemsmanagement%3Acrowbar%3A2.0&repository=openSUSE_Factory

I even tried triggering rebuilds for rubygem-actionmailer-3_2, but it
didn't change anything.

Help?!
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages