Mailinglist Archive: opensuse-buildservice (244 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS check causing questionable failure. [SOLVED]
  • From: Roger Oberholtzer <roger@xxxxxx>
  • Date: Fri, 15 Jun 2012 10:16:44 +0200
  • Message-id: <1339748204.15610.142.camel@acme.pacific>
On Fri, 2012-06-15 at 08:59 +0200, Marcus Meissner wrote:
On Fri, Jun 15, 2012 at 08:51:41AM +0200, Adrian Schröter wrote:
Am Freitag, 15. Juni 2012, 08:28:55 schrieb Roger Oberholtzer:
When I build the mingw32 package, OBS makes a
debug package. I did not (I think) request this. Part of the build
checks the source. In my case, I get this complaint:

mingw32-blt-debug-2.5-51.1
... running 01-check-debuginfo
... testing for empty debuginfo packages
!
!
//usr/src/packages/RPMS/noarch/mingw32-blt-debugsource-2.5-51.1.noarch.rpm:
empty debuginfo/debugsource package, deleting
!
... running 02-check-gcc-output
... testing for serious compiler warnings
(using /usr/lib/build/checks-data/check_gcc_output)
(using //.build.log)
E: mingw32-blt 64bit-portability-issue bltWindow.c:876

And then the build fails. Even though the RPMs I really wanted are
made...

Can I disable this check? Oddly, as I am building a 32-bit application,
I would not expect a 64-bit complaint. And I see in the code that there
is a #define for 32- and 64-bit compiles which the test ignores. The
complaint is in code that is for the 32-bit version.

Any help would be appreciated.

In fact that are not checks from OBS, but checks from the distributions.

So, in your case this check is in

post-build-checks

package. You may want to have a look there and propose a patch :)

Or just fix the bug in bltWindow.c:876 :(


A bug in BLT? Surely you jest :) Indeed, correcting the missing cast
solved the issue.

Part of the problem for me was that it was unclear on what the script
was basing the claim (Adrian's pointer helped me sort that). The
specific error is, in fact, not a 32-bit/64-bit issue. On both systems,
integers and pointers are the same size. I suspect the script only looks
at 'without a cast', and not that it is an integer and pointer that are
involved. Which is fine. But I wonder if it might not be helpful to also
report the text of the line in the log that triggered the error. Until I
installed part of OBS locally and looked at the script, this was not
obvious.




Yours sincerely,

Roger Oberholtzer

OPQ Systems / Ramböll RST

Office: Int +46 10-615 60 20
Mobile: Int +46 70-815 1696
roger.oberholtzer@xxxxxxxxxx
________________________________________

Ramböll Sverige AB
Krukmakargatan 21
P.O. Box 17009
SE-104 62 Stockholm, Sweden
www.rambollrst.se


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >