Mailinglist Archive: opensuse-buildservice (157 mails)

< Previous Next >
Re: [opensuse-buildservice] wine-devel-32bit in home:RedDwarf not available to x86_64 build
  • From: Cristian Morales Vega <reddwarf@xxxxxxxxxxxx>
  • Date: Tue, 3 Apr 2012 19:47:54 +0100
  • Message-id: <CAOWQn3QZ5r3hW5rRiwgbQzqB2jK3Awrii9yM=9AyLv641rbPiA@mail.gmail.com>
On 26 March 2012 22:16, Marcus Meissner <meissner@xxxxxxx> wrote:
On Mon, Mar 26, 2012 at 10:00:36PM +0100, Cristian Morales Vega wrote:
On 10 March 2012 19:12, Cristian Morales Vega <reddwarf@xxxxxxxxxxxx> wrote:
Now the problem with the 12.1 x86_64 build is that the "wine-devel"
package being installed is the i586 version instead of the x86_64 one.
But still no idea why it's happening only with 12.1 and not with
Tumbleweed...

I just removed the "ExportFilter:" line from my prjconf and wiped the
binaries to see what happens, but I am just shooting in the dark.

Now lmms is in multimedia:libs and I still have the problem with
Factory/x86-64. I guess that if the i586 builds after the x86-64 it
overwrites it's wine-devel or something like that? Sometimes it builds
but others it fails with errors like

/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld:
cannot find -lshell32

because of that wine-devel.i586 instead of wine-devel.x86-64 is installed.

actually the install was missing wine-32bit (wasnt correctly pulled in by
wine-devel-32bit)

I added it to your package now, and it is building currently ... lets see if
this works.

It doesn't.
Really, in a local build I saw wine-devel.i586 being installed instead
of wine-devel.x86_64 (plus wine-devel-32bit). That seems to be the
problem, but not sure what triggers it.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages