Mailinglist Archive: opensuse-buildservice (157 mails)

< Previous Next >
Re: [opensuse-buildservice] Upgrade to 2.99 (look like a 2.3) breaks the obs server
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Mon, 02 Apr 2012 20:20:52 +0200
  • Message-id: <6290024.DjGzP0D8GV@scherben>
Am Montag, 2. April 2012, 20:18:50 schrieb Adrian Schröter:
Am Montag, 2. April 2012, 19:26:02 schrieb Dominig ar Foll:
Hello,

I went through the pain to upgrade my obs-server to version 2.99 which
looks very much like a 2.3.
While the upgrade is fairly painful it's worth the pain. UI is better
and apache is more reliable than httplight.

On an OBS Light server appliance (http://wiki.meego.com/OBS_Light) the
upgrade can be done by a simple zypper update which upgrade and let you
with a broken server.

Hm, did you found issues which apply also to an upgrade to a standard obs
server
and are not covered by the README.UPDATERS ?

I guess that the same issue could occurs to any OBS server installation.

I have written a small howto which could help you. while waiting for the
problem to be corrected.

It is currently not possible to do it 100% automatic. But the upgrade should
be
documented in the README.UPDATERS file. It would be great if you can improve
that one if it is not sufficient (or make suggestions what could be handled
automatically).

I forgot to say, when you update via exchanging the 2.1 appliance with the 2.3
one, the
upgrade should update all data and run out-of-the-box without manual steps.

Please tell if that is not the case (But I dunno how to do that with the meego
version, I admit).

bye
adrian

--
Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >