Mailinglist Archive: opensuse-buildservice (327 mails)

< Previous Next >
[opensuse-buildservice] 404 remote error: remote error Not Found
  • From: Pascal Bleser <pascal.bleser@xxxxxxxxxxxx>
  • Date: Thu, 28 Apr 2011 19:03:10 +0200
  • Message-id: <20110428170310.GH2906@hera>
Our Packman OBS instance (at http://pmbs.links2linux.org) gets
quite a number of mysterious build failures that only provide
the following log message:
404 remote error: remote error Not Found

That's it. No more, no less ;)

It only happens with builds against
openSUSE:11.4+openSUSE:11.4:Update, and not always either (some
packages work, and the next fails).

Can't find anything suspicious in the logs but I don't even know
where to start looking, so I could only make some (almost)
random greps.
Of course, the log files not having log levels and not always
timestamps, and being full of debug information everywhere
doesn't help isolating problems :(

Another weirdness is that when we trigger rebuilds on those
failed builds, "nothing" happens. Well, some stuff happens in
the logs (but as said, can't parse it, too much cruft), but
nothing in the scheduler log -- hence the OBS doesn't even try
to rebuild it in the first place.

This is an OBS 2.1.7 instance running on openSUSE 11.4/x86_64.
We're using the "public" HTTP (not HTTPS) connectivity for
remoting to build.opensuse.org

Needless to say that it's pretty critical, as there are many
packages that we cannot provide to our very large user base for
11.4 :\

I'd be thankful for any hint or anything I could be looking for.
I can also give ssh access to our OBS chroot to certain people.

cheers
--
-o) Pascal Bleser
/\\ http://opensuse.org -- we haz green
_\_v http://fosdem.org -- we haz conf
< Previous Next >