Mailinglist Archive: opensuse-buildservice (206 mails)

< Previous Next >
Re: [opensuse-buildservice] setup trouble
On 02/20/2011 01:49 PM, Robert Schweikert wrote:

I am having a little trouble getting the osc commands working on a
laptop. AFAIK there's nothing special.

Running openSUSE 11.3, x86-64, GNOME desktop

-> rpm -qa | grep osc

When I run "osc help" I am prompted to setup KDE wallet, not that big of
a deal but I do not remember doing this previously when I setup osc on
another machine. (I do not have an alias ala "osc --no-keyring" setup).

So when KDE wallet starts I get

Connecting to deprecated signal

Then after I set it up I end up with a stupid popup to enter my wallet
password everytime I run an osc command.

I do not have kdewalletmanager installed (on either system).

I also tried copying ~/.oscrc from the machine where things work to the
machine that is giving me fits, but to no avail.

When I installed kwalletmanager on the machine giving me trouble and set
things such that the stupid popup does no longer appear I'd still get
the annoying "Connecting to deprecated signal..." message.

Somewhere along the line I probably messed something up, help in
straightening things out is much appreciated.



I highly recommend you add

Update osc from there and add spec-cleaner and webpin, as well.
Spec-cleaner does just that, making the formatting consistent and more
readable. Webpin is software search on the commandline. If you are doing
local build, the updated build script is also recommended.

I am thinking out loud perhaps osc should get a maintenance update.

Hope that helps,
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >