Mailinglist Archive: opensuse-buildservice (158 mails)

< Previous Next >
Re: [opensuse-buildservice] Problem building a library package for OpenSUSE_11.2
  • From: Angelos Tzotsos <gcpp.kalxas@xxxxxxxxx>
  • Date: Tue, 07 Dec 2010 00:27:15 +0200
  • Message-id: <4CFD6343.5050409@xxxxxxxxx>
Thank you Adrian,

Problem was solved :)


On 12/06/2010 02:52 PM, Adrian Schröter wrote:
On Friday 03 December 2010 19:36:56 Angelos Tzotsos wrote:
Hello everyone,

I am a new user of Build Service but an old user of OpenSUSE.
I am trying to provide a repository for a project I am involved in,
called OrfeoToolbox.

With the help from people over the #opensuse-buildservice Freenode
channel, I managed to fix some errors in the spec file I created,
and my package now builds correctly (with no errors, only few
warnings) for Factory and OpenSUSE_11.3

The spec file is here:

When I try to build for OpenSUSE_11.2 I get the following error:
|... running 03-check-binary-kernel-log

... running 04-check-filelist

... checking filelist

OrfeoToolbox-3.6.0-74.1.i586.rpm: directories not owned by a 

 - /usr/lib/otb

OrfeoToolbox-devel-3.6.0-74.1.i586.rpm: directories not owned by a

 - /usr/lib/otb

System halted.

|I got suggestions to list every file of my package in the

%files section, but they are way too many to do this.

Also, I tried other ways of declaring my file list, like
/usr/lib/otb/* with same results (errors only for OpenSUSE_11.2)

Can someone please propose a solution to this?
Either package the entire directory with all content via


or just package the directory:

%dir /usr/lib/otb

or maybe better via

%dir %_libdir/otb

in case it is different on lib64 systems.


Angelos Tzotsos
Remote Sensing Laboratory
National Technical University of Athens

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >