Mailinglist Archive: opensuse-buildservice (272 mails)

< Previous Next >
Re: [opensuse-buildservice] osc co doesn't work while using cntlm proxy
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Wed, 10 Nov 2010 21:30:13 +0100
  • Message-id: <201011102130.13661.adrian@xxxxxxx>
Am Mittwoch, 10. November 2010, 20:43:33 schrieb Praveen_Paladugu@xxxxxxxx:

I removed the following line from the definition of headers.update in
/srv/www/obs/api/app/controllers/build_controller.rb file
'Content-Disposition' => %(attachment; filename="#params[:filename]}"),

This change doesn't seem to affect the headers returned to the "osc co"

right, that has only an effect when downloading the built packages ...

Also, I have access to two versions of OBS. One running 2.1.0 and the other
running 1.6.0.

The response from the 2.1.0 version has " Content-Disposition: attachment" in
the headers and the version 1.6.0 has ' Content-Disposition: attachment;
filename = "kiwi.spec" ' (along with the filename) in the response.

The proxy server doesn't seem to have a problem with version 2.1.0. But the
response from 1.6.0 is the one failing.

Uh, we don't support 1.6 since quite some time....

I can remember that we fixed a number of issues with proxies since then, but I
would need to go
through the quite long git history to find out more ....

sorry, I can't remember anymore what we changed

Weird of all, both the versions 1.6.0 and 2.1.0 have the same line for
"Content-Disposition" header in build_controller.rb.

Thank you

-----Original Message-----
From: Adrian Schröter [mailto:adrian@xxxxxxx]
Sent: Wednesday, November 10, 2010 9:09 AM
To: opensuse-buildservice@xxxxxxxxxxxx
Cc: Paladugu, Praveen
Subject: Re: [opensuse-buildservice] osc co doesn't work while using cntlm

Am Dienstag, 9. November 2010, 21:00:59 schrieb Praveen_Paladugu@xxxxxxxx:
Hi All,

I am using cntlm (version 0.35.1-1) proxy to talk to outside network. With
the proxy configured properly, I am able to run:

" osc log prjname/pkgname" command and get the expected output.

But, when I run

"osc co prjname/pkgname" command, I get

Server returned an error: HTTP Error 502: Proxy Error ( The HTTP
message includes an unsupported header or an unsupported combination of
headers. )

I tried the above osc command with "-H" flag to check the HTTP headers. The
failure occurs the first time, osc tries to download a file. From what I
noticed, the header the proxy server is having a problem with is:

Content-Disposition: attachment; filename = "kiwi.spec"

Has anybody seen this problem? Is there a known workaround?

This header is for nicer web browser support when downloading a binary file.

However, it looks like it is not really needed with the browsers I have
So we may can consider to remove it fro OBS 2.2.

You can remove the header on your api server in
and test if it works.


Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >