Mailinglist Archive: opensuse-buildservice (332 mails)

< Previous Next >
Re: [opensuse-buildservice] issue with BS from scratch
  • From: "Hans-Peter Jansen" <hpj@xxxxxxxxx>
  • Date: Fri, 23 Jul 2010 11:12:20 +0200
  • Message-id: <201007231112.20638.hpj@xxxxxxxxx>
On Friday 23 July 2010, 08:24:23 Adrian Schröter wrote:
On Thursday 22 July 2010 23:06:13 Hans-Peter Jansen wrote:

Please find a respective documentation fix attached.

Thanks, I have imported most parts of it.

Nice, even better but you missed one ;-) See below..

Also, the hint to run OBS as an appliance is interesting, but unfortunately
not written yet.


You need to use

when specifing the repository. is the local project which
provides all content from the remote instance.

Understood. Now I have successfully added a project and a package in my bs.

Proceeding to the distribute step:

$ cd ~/VCS/GIT/build-service/dist
$ OSCOPT="-A http://localhost:81"; ./distribute
Server returned an error: HTTP Error 404: Not Found
Error getting meta for project 'openSUSE:Tools:Devel' package 'obs-all-svn'
Unknown project 'openSUSE:Tools:Devel'

Hmm, even adding the missing prj/pkg the same way as done above keeps this
error state. Given, that development is done in git, the svn references
doesn't spread confidence, either.

Nevertheless, from this point, I'm able to add some source to the project in
familiar ways, e.g. I've checked out openSUSE:Tools/obs-server from my OBS,
copied the files from the official openSUSE:Tools/obs-server BS package,
which leads to the error condition below:

nothing provides obs-common, nothing provides rubygem-rails-2_3 >= 2.3.5,
nothing provides rubygem-rmagick, nothing provides build >= 2009.05.04,
nothing provides perl-BSSolv

How do I trick my BS to really use the packages without adding
each of them manually?

--- dist/README.SETUP~ 2010-07-23 10:47:53.641777321 +0200
+++ dist/README.SETUP 2010-07-23 10:51:59.146291919 +0200
@@ -349,7 +349,7 @@ i586:

osc -A http://$servername:81 meta prj openSUSE:Tools -e

-check whether that worked on
+check whether that worked on http://$servername/project/list_all

osc -A http://$servername:81 meta pkg openSUSE:Tools obs-server -e

< Previous Next >
Follow Ups