Mailinglist Archive: opensuse-buildservice (306 mails)

< Previous Next >
Re: [opensuse-buildservice] anonymous access support
  • From: Jan Engelhardt <jengelh@xxxxxxxxxx>
  • Date: Wed, 30 Jun 2010 08:55:50 +0200 (CEST)
  • Message-id: <alpine.LSU.2.01.1006300847360.2225@xxxxxxxxxxxxxxx>

On Wednesday 2010-06-30 07:57, Adrian Schröter wrote:
Processing StatusController#workerstatus (for ::ffff:10.239.36.25 at
2010-06-30 11:09:50) [GET]
[D|# 8304] AUTH:
[D|# 8304] remote_host:
[D|# 8304] remote_addr: ::ffff:10.239.36.25
[D|# 8304] no authentication string was sent

Seems the request.env['REMOTE_HOST'] is NULL and it failed at the host check
at:
[...app/controllers/application_controller.rb]
if @http_user.nil? and CONFIG['allow_anonymous'] and CONFIG['webui_host']
and [ request.env['REMOTE_HOST'], request.env['REMOTE_ADDR'] ].include?(
CONFIG['webui_host'] )

Try to specify the ip addr as "webui_host". lighttpd 1.4 seems to require that
since it does no dns lookup for that.

Using a php script with lighttpd and dumping the environment shows
indeed that no REMOTE_HOST is defined.

So it seems application_controller.rb also checks REMOTE_ADDR.
Well, as I mumbled previously "just which one address _should_ I put there?"

::1, 127.0.0.1, or any of the two public addresses...
anyway I tried that (adding a debug REMOTE_ADDR line) and then chose
the one. Anonymous access works now,
but lighttpd not doing a resolution woha, was nowhere described.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups