Mailinglist Archive: opensuse-buildservice (306 mails)

< Previous Next >
Re: [opensuse-buildservice] Question about Repository
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Mon, 28 Jun 2010 08:13:07 +0200
  • Message-id: <201006280813.07648.adrian@xxxxxxx>
On Sunday 27 June 2010 22:41:13 Sascha 'saigkill' Manns wrote:
Hello Mates,

i have updated my freediams Package in the medical Repository
(http://download.opensuse.org/repositories/medical/). It
needs libqt4-devel >= 4.6.2. So i have added a BuildRepository
"KDE_Qt_openSUSE_11.2".
But the status is "Unresolvable".
Anyone knows how to fix that?

You have added another repo in your project which builds against KDE:Qt. And
that one is not showing
unresolvable. Btw, when you click on the "unresolvable" the webui shows which
dependency can get resolved
exactly.

I suppose you want to modify your existing repositories instead and build
against the KDE:Qt repos.

You can do so with the repository editor or in the project meta file directly.
Either via osc or view webui -> Project view -> Advanced -> Raw Config.

Such lines would lead to building packages, I think:
...
<repository name="openSUSE_11.0">
<path project="KDE:Qt" repository="openSUSE_11.0"/>
<arch>x86_64</arch>
<arch>i586</arch>
</repository>
<repository name="openSUSE_11.1">
<path project="KDE:Qt" repository="openSUSE_11.1"/>
<arch>x86_64</arch>
<arch>i586</arch>
</repository>
<repository name="openSUSE_11.2">
<path project="KDE:Qt" repository="openSUSE_11.2"/>
<arch>x86_64</arch>
<arch>i586</arch>
</repository>
...


--

Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >