Mailinglist Archive: opensuse-buildservice (306 mails)

< Previous Next >
Re: [opensuse-buildservice] Osc 0.127 bug
  • From: Dave Plater <davejplater@xxxxxxxxx>
  • Date: Wed, 16 Jun 2010 14:09:46 +0200
  • Message-id: <4C18BF0A.4060508@xxxxxxxxx>
On 06/16/2010 01:39 PM, Adrian Schröter wrote:
On Wednesday 16 June 2010 13:33:06 Dave Plater wrote:

On 06/16/2010 11:16 AM, Marcus Hüwe wrote:

Hi,

On 2010-06-16 09:08:10 +0200, Dave Plater wrote:


Hi, I'm currently using osc-0.127 and every time I check in a package it
complains about _link and the backup files from quilt and kwrite etc.
ending with a tilde "~". The previous versions of osc ignored these files.
Is it ok to report these things on this list?


Can you be a bit more "precise"?:) What do you mean with "complain"?



Marcus


Sorry, I mean that I get the message :-
Attention, qtractor-0.4.6 is not mentioned in spec files as source or patch.
Attention, qtractor.spec~ is not mentioned in spec files as source or patch.
Is this correct? [N/y/d] (y to ignore) y

The first message is for the directory qtractor-0.4.6 produced by
unpacking the tarball, the second one relates to a backup file produced
by kwrite, quilt also creates tilde "~" suffixed backup files for patches.
The first message, which needs no attention isn't so bad, I don't think
you can check in directories anyway but the second is irritating and
distracts from actually noticing a patch that should have been added
with osc add for instance. I don't think it's common practice to suffix
files with ~ anyway. Other than that osc-0.127 has been working fine,
does it pick up packaging errors?

This is not osc, but the source validator from "osc-source_validator" package.

It looks we can finetune this check a bit more and ignore files, which are not
tracked by osc. (The validator scripts need to keep running also without osc).

In case you want to work on this:

osc bco openSUSE:Tools osc-source_validator

bye
adrian


Now I see the light, I've still got the unstable version of
osc-source_validator left over from when I test drove the first 0.127
version, the version from tools still complains though.
Thanks for the explanation.
Dave P
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >