Mailinglist Archive: opensuse-buildservice (348 mails)

< Previous Next >
Re: [opensuse-buildservice] osc co/up hangs and eventually corrupts working copy
  • From: Tejas Guruswamy <masterpatricko@xxxxxxxxx>
  • Date: Mon, 26 Apr 2010 17:49:19 +0100
  • Message-id: <4BD5C40F.2050802@xxxxxxxxx>
On 26/04/10 16:16, Olaf Hering wrote:
This weekend I tried to run the following command several times:

osc co --unexpand-link home:duwe:crosstools

The cross-* packages which are linked were downloaded without issues,
but as soon as the master-binutils package is supposed to be downloaded,
osc hangs.
lsof shows that 2MB of binutils-tar.bz2 are downloaded, quickly, but
then osc hangs for many hours (or even days, I havent tried) without
progress nor error messages.

...

I'm using osc 0.125.5 on openSuSE 11.2-x86_64.

Not a solution, but AFAIK osc 0.126 implemented progress bars for osc
co. Its available in OBS openSUSE:Tools

Might give you some more information (along the debug option flags, I
forget the syntax) as to what is going on.

Or maybe upgrading will fix the issue entirely.

Regards,
Tejas
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References