Mailinglist Archive: opensuse-buildservice (182 mails)

< Previous Next >
[opensuse-buildservice] problem with local OBS (linked openSUSE.org)
  • From: Christian <chris@xxxxxxxxxxxxxxxx>
  • Date: Sun, 07 Feb 2010 22:50:49 +0000
  • Message-id: <4B6F43C9.1030507@xxxxxxxxxxxxxxxx>
Hi,

obs is telling "expansion error", but I know that package is available.
My package had this expansion errors:
looking at high prio SIT:asterisk (0/1/1/0/23)
looking at med prio SIT:asterisk/SLE_11 (0/0/1/0/23)
- SIT:asterisk/SLE_11
expanding dependencies
sorting 12 packages
- mor (spec)
expansion errors:
nothing provides rubygem-rails = 1.2.6
nothing provides rubygem-rake >= 0.8.7
done: 11
expansion error: 1
building: 0, notready: 0
took 1 seconds to check the packages
looking at low prio SIT:asterisk/SLE_11 (0/0/0/0/23)
- SIT:asterisk/SLE_11
expanding dependencies
sorting 12 packages
- mor (spec)
expansion errors:
nothing provides rubygem-rails = 1.2.6
nothing provides rubygem-rake >= 0.8.7
done: 11
expansion error: 1
building: 0, notready: 0
took 1 seconds to check the packages
waiting for an event...

so i modified prjconf and added my ruby repo:
<repository name="SLE_11">
<path project="openSUSE.org:SUSE:SLE-11" repository="standard"/>
<path project="SIT:ruby" repository="SLE_11"/>

after that scheduler is telling:
calculating project dependencies...
sorting projects and repositories...
looking at high prio SIT:asterisk (0/1/1/0/23)
looking at med prio SIT:asterisk/SLE_11 (0/0/1/0/23)
- SIT:asterisk/SLE_11
expanding dependencies
sorting 12 packages
- mor (spec)
expansion errors:
nothing provides rubygem-rake >= 0.8.7
done: 11
expansion error: 1
building: 0, notready: 0
took 1 seconds to check the packages
looking at low prio SIT:asterisk/SLE_11 (0/0/0/0/23)
- SIT:asterisk/SLE_11
expanding dependencies
sorting 12 packages
- mor (spec)
expansion errors:
nothing provides rubygem-rake >= 0.8.7
done: 11
expansion error: 1
building: 0, notready: 0
took 1 seconds to check the packages
waiting for an event...

the first expansion error has vanished "rubgem-rails = 1.2.6"
but second does not.
And "rubygem-rake" is in SIT:ruby with version 0.8.7.

So what is the problem ? What can I do ?
My obs version:
SIT obs:/srv/obs/log # rpm -qa | grep obs
obs-utils-1.6.0-15.2
obs-api-1.6.0-15.2
obs-server-1.6.0-15.2

Thanks
Chris

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages