Mailinglist Archive: opensuse-buildservice (306 mails)

< Previous Next >
Re: [opensuse-buildservice] osc 0.120 for x84_64 uses lib directory instead of lib64 and failing to run
That may be leakage from newest release of openSUSE. There was a push
for the latest version of openSUSE to support not having python programs
to use lib64 since the python code should be arch-independent and thus
to have to the python packages be noarch, they needed to use lib instead
of lib64. Are you install this on an older version of openSUSE or some
other distro?

On Fri, 2010-01-08 at 17:03 -0600, z wrote:
Hi.
I just installed osc 0.120-2.1 from openSUSE-11.2-oss, and it has a
problem. It installs itself in /usr/lib/python2.6/site-packages/osc,
and python can't find it, when i run:
# osc
Traceback (most recent call last):
File "/usr/bin/osc", line 7, in <module>
from osc import commandline
ImportError: No module named osc

i managed to overcome it by creating a symlink
/usr/lib64/python2.6/site-packages/osc, but this bug is obviously
should be fixed in osc build.


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References