Mailinglist Archive: opensuse-buildservice (260 mails)

< Previous Next >
Re: [opensuse-buildservice] osc 0.124 and obs 1.6 Compatibility
  • From: Anas Nashif <nashif@xxxxxxxxxxxxxxx>
  • Date: Tue, 22 Dec 2009 08:42:15 -0500
  • Message-id: <42AB0B84-B56D-4D2A-BE3F-D15D361E03A4@xxxxxxxxxxxxxxx>

On 2009-12-21, at 10:35 AM, Adrian Schröter wrote:

Am Montag, 21. Dezember 2009 16:16:03 schrieb Anas Nashif:
On 2009-12-21, at 9:38 AM, Adrian Schröter wrote:
Am Montag, 21. Dezember 2009 15:12:14 schrieb Anas Nashif:
Hi,
While many operation using osc 0.124 work as expected with obs 1.6.0, I
just noticed that submitrequest does not work and fails with:

constructor needs either REXML::Element, String or Hash

Is the 1.6 API compatible with osc 0.124?

it should be, but frankly, I don't have a running 1.6.0 around anymore.

I really want to use the 1.7 snapshots, but this is undergoing heavy
development right now. I spent some time trying to use the latest 1.6.83
packages, but without success, What is the best way to keep in sync with
the git HEAD and deploy changes from git?

http://en.opensuse.org/Build_Service/Run_from_git

Thanks, I just install the 1.6.85 packages which are very close to git. The
only thing not working for me now is
the "Server Status" in the webui, which gives me an error, probably something
related to XML..

[D|#23696] User nashif initialised
[D|#23696] User's source backend <:>
[D|#23696] Cache read: workerstatus
[D|#23696] Cache write: workerstatus
[I|#23696] Sending data
[F|#23696]
NoMethodError (undefined method `bytesize' for nil:NilClass):
app/controllers/status_controller.rb:80:in `workerstatus'
public/dispatch.fcgi:24


I also had to add

EXTENDED_BACKEND_LOG = false

to production_slave.rb

when I first run rake db:migrate in the api, there was an error about not
finding common/activexml. I had to update share-resources from git which seem
to be of an old version in the package in Unstable..







Can you send me a bit more detailed snippet from your server log ?

[nashif@taybeh quilt]$ osc -d --apiurl http://api.xxxxx.org sr Trunk -m
"spec cleanup" GET http://api.xxxxx.org/source/Trunk/quilt/_meta
GET

... interessting ... one could argue that this is a server side bug, but I
wonder why we trigger this suddenly with a new osc.

This still worked with osc 0.123 ?

Yes, same with 0.123.

Anas



bye
adrian


--

Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups