Mailinglist Archive: opensuse-buildservice (260 mails)

< Previous Next >
[opensuse-buildservice] Cannonical names for debs
While testing osc 0.123, I ran into an issue with debianutils not being
detected in the cache because it has not release, so the local file://
mirror fails to find the file since something adds -0 as a default
release. But, when I was in the code I noticed that
osc.fetch.Fetcher.fetch was constructing a canonical name for debs as

canonname = '%s-%s.%s.%s' % (, pkgq.version(), arch,

which would give


but, the naming scheme for debs uses _ has a separator for verision and
arch. The actual deb is called


Is this just an error in expanding osc build to handle deb based bundles
and should be fixed or was a decision made to use . has a separator for
the canonical names for both rpms and debs? In which case, when does
this canonical name get translated to the correct name since the debs in
the download url use the '_' separator?

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups