Mailinglist Archive: opensuse-buildservice (248 mails)

< Previous Next >
Re: [opensuse-buildservice] Strange expansion error??
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Sat, 31 Oct 2009 12:32:34 +0100
  • Message-id: <20091031113234.GA5578@xxxxxxx>
On Sat, Oct 31, 2009 at 11:32:53AM +0100, Richard Bos wrote:
Why do I get this strange error message (strange as in: did not expect the
error message to be like this)
"expansion error: nothing provides ib2008 needed by inkomstenbelasting"
for the following distributions:

ib2008> osc r -a i586 | grep expa
Fedora_11 i586 / x86_64
openSUSE_11.2 i586 / x86_64
openSUSE_Snapshot i586 / x86_64

Many others distributions are just build nicely with the same spec file.

ib2008 is indeed required by the rpm inkomstenbelasting, but the package
ib2008 should not be blocked because the rpm inkomstenbelasting needs ib2008.
It only seem to happen for packages that are build recently...

The link to the package is:
https://build.opensuse.org/package/show?package=ib2008&project=home%3Arbos%3Aib
(repository: home:rbos:ib)

You have a circular dependency between the two packages.

ib2008 Buildrequires inkomstenbelasting, which in turn Requires ib2008.

You could try
BuildRequires: -ib2008
in ib2008 itself, not sure if it helps.

But you should breaks this cycle manually to let it build once, or do not have
a cycle at all.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References