Mailinglist Archive: opensuse-buildservice (312 mails)

< Previous Next >
Re: [opensuse-buildservice] Problem with SLE 11 conflict libSDL-dev...
  • From: Pavol Rusnak <prusnak@xxxxxxx>
  • Date: Thu, 23 Jul 2009 13:05:54 +0200
  • Message-id: <4A684412.8020909@xxxxxxx>
Adrian Schröter wrote:
Am Donnerstag, 23. Juli 2009 01:39:50 schrieb Boyd Lynn Gerber:
Hello,

Trying to get /games/vultures/... working on SLE 11 I get the following
problem.

This is a packaging bug, please report to the package owners.

Actually it isn't. Factory and 11.1 build fine in "games" project. But
SLE11 tries to install both SDL-devel and libSDL-devel.

I have the following lines in prjconf of game project:

Prefer: -SDL
Prefer: -SDL-devel
Prefer: -SDLmm
Prefer: -SDLmm-devel
Prefer: -SDL_gfx
Prefer: -SDL_gfx-devel
Prefer: -SDL_image
Prefer: -SDL_image-devel
Prefer: -SDL_mixer
Prefer: -SDL_mixer-devel
Prefer: -SDL_net
Prefer: -SDL_net-devel
Prefer: -SDL_Pango
Prefer: -SDL_Pango-devel
Prefer: -SDL_sound
Prefer: -SDL_sound-devel
Prefer: -SDL_ttf
Prefer: -SDL_ttf-devel

and the new package libSDL-devel has this in spec.

Provides: SDL-devel = %{version}
Obsoletes: SDL-devel < %{version}

For some strange reason this is not honored and thus does not work in
SLE11 repo.

--
Best Regards / S pozdravom,

Pavol RUSNAK SUSE LINUX, s.r.o
openSUSE Community Multiplier Team Lihovarska 1060/12
PGP 0xA6917144 19000 Praha 9, CR
prusnak[at]suse.cz http://www.suse.cz
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >