Mailinglist Archive: opensuse-buildservice (239 mails)

< Previous Next >
[opensuse-buildservice] Repository order and package versions
  • From: Cristian Morales Vega <cmorve69@xxxxxxxx>
  • Date: Thu, 7 May 2009 18:36:02 +0200
  • Message-id: <8235e6f40905070936w33a76f2r41879d1f5814fb78@xxxxxxxxxxxxxx>
Hi,

I want to create a package for openSUSE 11.1 that requires Qt >= 4.5,
and so I say in the BuildRequires entry. That means I must compile it
against the version from KDE:Qt, but there are other packages in the
repo, and I would prefer that they use the official Qt packages.
Using
<repository name="openSUSE_11.1">
<path project="KDE:Qt" repository="openSUSE_11.1"/>
<path project="openSUSE:11.1" repository="standard"/>
<arch>x86_64</arch>
<arch>i586</arch>
</repository>
all the packages will use the version from KDE:Qt.
So I though that using
<repository name="openSUSE_11.1">
<path project="openSUSE:11.1" repository="standard"/>
<path project="KDE:Qt" repository="openSUSE_11.1"/>
<arch>x86_64</arch>
<arch>i586</arch>
</repository>
packages that BuildRequire "libqt-devel" would use the one from
openSUSE:11.1, and the ones that BuildRequire "libqt-devel >= 4.5.0"
would use the one from KDE:Qt.
But at practice what I get with the second option is an expansion
error complaining about the lack of "libqt-devel >= 4.5.0".

...well, it isn't missing, it just should continue searching. Bug or
something unfixable given the internal working of the OBS?
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups