Mailinglist Archive: opensuse-buildservice (189 mails)

< Previous Next >
[opensuse-buildservice] File not found with rolling rpm (%{buildroot})
  • From: Ben Martin <monkeyiq@xxxxxxxxxxxxxxxxxxxxx>
  • Date: Sun, 22 Feb 2009 22:29:21 +1000
  • Message-id: <1235305761.6884.320.camel@xxxxxxxxxxxxxxx>
I've recently tried to rebuild libferris and it's dependencies for
Fedora 10. I got through all the dependencies fine, and the build and
install parts of libferris itself work, but for whatever reason it is
not picking up the correct path when it tries to create the rpm itself.

I've tinkered with the .spec file, which worked fine before when making
RPMs for Fedora 9 others.

Project is here:

Log is here:

The make install uses
to base things into /tmp/build/libferris-root, for example:

But it seems that the location that RPM is expecting the files is at:

If anyone has any hints it would be great. The downside is that
libferris takes 'a while' to build, so trying to work out what is wrong
by slight tinkering of the .spec file is painfully slow.

Note that I added 6 or so leading
to the %files section to try to kludge around this. So please ignore
that incorrectness if you take a look at the spec.

< Previous Next >
This Thread
  • No further messages