Mailinglist Archive: opensuse-buildservice (339 mails)

< Previous Next >
Re: [opensuse-buildservice] java version: which BuildRequires?
  • From: Thomas Schmidt <tschmidt@xxxxxxx>
  • Date: Mon, 17 Mar 2008 14:48:07 +0100
  • Message-id: <47DE7697.1090602@xxxxxxx>
Roberto Mannai schrieb:
Hi all
I'm new to the Build Service, and fast I'm getting crazy :) My project
must be compiled with a JVM >= 1.5, but I cannot guess how to label
the required package:

BuildRequires: java-1_5_0-gcj-compat-devel ?
BuildRequires: java-1_5_0-sun-devel ?

There is a macro which expands to the best package per system:

BuildRequires: java-devel >= 1.5

Greetings


If I understood well, the package name depends on the target system
(openSUSE_10.3 packages are different than openSUSE_Factory ones).
java-1_5_0-sun-devel on openSuse10.3 does not work anymore.

Any help is very welcome :)
Ciao
rob
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx



--
Thomas Schmidt (tschmidt [at] suse.de)
SUSE Linux Products GmbH :: Research & Development :: Internal Tools
"Don't Panic", Douglas Adams (1952 - 11.05.2001)
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References