Mailinglist Archive: opensuse-buildservice (219 mails)

< Previous Next >
Re: [opensuse-buildservice] build a package locally using "build" and bs-packagecache
  • From: "Dr. Peter Poeml" <poeml@xxxxxxx>
  • Date: Tue, 12 Feb 2008 13:42:21 +0100
  • Message-id: <20080212124221.GD30274@xxxxxxx>
On Mon, Feb 11, 2008 at 12:48:59PM -0600, Michael Wolf wrote:

On Mon, 2008-02-11 at 15:21 +0100, Marcus Rueckert wrote:
On 2008-02-11 15:16:59 +0100, Wolfgang Rosenauer wrote:
I've tried to build a package on my local system using "build" and
reusing the bs-packagecache as RPM repository.

That fails most probably because these ugly directory names containing

build --root=/var/tmp/build-root cairo.spec --norootforbuild --rpms

fails to find the RPMs there.
I guess I tried every type of quoting for the colon but everything failed.
To see if it's really the colon I've created a symlink w/o a colon to
that directory and there it works.

why not use osc build?

Probably because osc needs to phone home every time.

I have a patch that applied to older versions of osc that made it phone
home less often. But it only worked in limited cases; if you changed
BuildRequires:, it would fail. So it was of limited use in practice --
a speed hack instead of genuine new functionality -- so I haven't
bothered respinning it yet.

Yes, it would be nice to revisit this. At least as an option (which
doesn't honor changed buildrequires) it would be useful in many
situations, I guess.

"WARNING: This bug is visible to non-employees. Please be respectful!"

SUSE LINUX Products GmbH
Research & Development
< Previous Next >