Mailinglist Archive: opensuse-buildservice (314 mails)

< Previous Next >
Problem with truecrypt-kmp-package (was: [opensuse-buildservice] A different kernel is installed when installing kmp-packages: Wrong dependencies?)
  • From: Johannes Kastl <ojkastl@xxxxxx>
  • Date: Mon, 07 Jan 2008 11:12:58 +0100
  • Message-id: <4781FB2A.4060303@xxxxxx>
Hi everyone,

Adrian Schröter schrieb:
well it is valid to install any of the kmp packages dependency wise, but of
course this does not help you here. I believe the installer should offer you
choices here instead of simply pick something.

Why? If kernel-default is installed, install kmp-default. Basta. ;-)
Why should I choose another kernel?

actually, without checking this really, I believe it is a problem with apt.

I am sorry to say this, but I can confirm this. It seems like a problem
in apt.

Does zypper not offer you a list of choices in the same situation ? I mean
before any trucrypt-kmp-* package is installed ?

I never really used zypper on my 10.2, cos it was slow as hell. Now I
configured the repos, and tried to install the truecrypt package in the
security:/privacy repo. And zypper just wants to install truecrypt and
truecrypt-kmp-default.

I then tried the newly built stuff Vittorio Manfredini, the
network:/telephony maintainer, built. And again zypper installs the
packages right, and apt wants to install many other packages, including
kernels and xen.

So: Seems like a bug in apt. Ill ask on the apt list.

Thanks,
OJ
--
When once you have tasted flight, you will forever walk the earth with
your eyes turned skyward, for there you have been and there you will
always long to return. (Leonardo da Vinci)

< Previous Next >