Mailinglist Archive: opensuse-buildservice (170 mails)

< Previous Next >
Re: [opensuse-buildservice] Expansion error on Fedora 7 and 8
  • From: Jordi Mas <jmas@xxxxxxxxxxxxxx>
  • Date: Mon, 17 Dec 2007 15:15:54 +0100
  • Message-id: <4766849A.4010002@xxxxxxxxxxxxxx>
En/na Adrian Schröter ha escrit:
On Sunday 16 December 2007 15:56:37 wrote Jordi Mas:
Hello,

I'm trying to build gbrainy package[1] on Fedora 7 and Fedora 8 (it
builds correctly on OpenSuse). I get the following error:

"nothing provides glade-sharp2, nothing provides gnome-sharp2"

It looks like the substitutes for these packages should be added for
Fedora 7 and Fedora 8.

Any suggestion on how to fix this?

I have briefly looked over the *mono* and *glade* package list in Fedora, but I did not see any of these packages. Are you sure they are available in Fedora distri at all ? Do you know their names ?
Adrian,

I turns out that in Fedora gtk-sharp2[1] provides also the glade
requirements (they are packed together) and that gnome-sharp[2] provides
also the gnome-sharp2 bindings.

What is the best of way of handling this? Substitutes or may be
conditionals in the .spec file?

Thanks for your help,

[1]
http://rpm.pbone.net/index.php3/stat/4/idpl/5336123/com/gtk-sharp2-2.10.0-6.fc8.i386.rpm.html
[2]
http://rpm.pbone.net/index.php3/stat/4/idpl/5313691/com/gnome-sharp-2.16.0-5.fc8.i386.rpm.html

--

Jordi Mas i Hernàndez, HomePage http://www.softcatala.org/~jmas/
Bloc personal http://www.softcatala.org/~jmas/bloc/
Planeta Softcatalà: http://www.softcatala.org/planet/



---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >