Mailinglist Archive: opensuse-buildservice (209 mails)

< Previous Next >
[opensuse-buildservice] Dependencies: what if some distro have it, some distros don't?
  • From: John Pye <john@xxxxxxxxxxxxxxxxxx>
  • Date: Sat, 23 Jun 2007 22:09:11 +1000
  • Message-id: <467D0D67.8020304@xxxxxxxxxxxxxxxxxx>
Hi all

I have a package that needs a fairly recent version of SCons in order to
build. This version is available in most of the newer distros, but seems
to be missing in some others, specifically openSUSE 10.2 and Mandriva 2006.

There is a SCons package somewhere else in the Build Service and I can
link to that if I want. However I am not sure how this work when for
example FC6 already has the required version in the 'extras' repostory,
versus openSUSE 10.2, which doesn't have it.

Is there a way I can specify for the Build Service to use my local
package *only when* a satisfactory version is not available in the base
repository? Or is this already the default behaviour?

Cheers
JP
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups