Mailinglist Archive: opensuse-buildservice (193 mails)

< Previous Next >
Re: [opensuse-buildservice] zope project
  • From: Martin Kudlvasr <mkudlvasr@xxxxxxx>
  • Date: Wed, 25 Apr 2007 19:22:22 +0200
  • Message-id: <462F8E4E.5070707@xxxxxxx>
Joachim Werner wrote:
 > I've just double-checked: While Zope 2.8.9 (latest from 2007-03-25)
does work
> with Python 2.4, the supported Python version is 2.3.5. If we have to ship it 
> with its own Python, shouldn't we use the supported one, not the last one 
> known to not cause major problems?

Hi Joe,

2.10.3 is the latest from 2007-03-25 and it has TARGET="2.4.4"

> 
> OTOH as Zope3 explicitly needs a Python 2.4.4 we'd need to separate the two. 
> So maybe the Python 2.4.x choice is an acceptable compromise ...

so I only have to update zope (I should do that anyway).

> 
> BTW, do we have any feedback from the Zope community if they want to get rid 
> of this problem any time soon? I'm a big Zope fan in general, but this 
> requiring a certain Python version really causes more problems that it 
> should.

As I perceive the problem, Jim Fulton doesn't want to split the man
force between seamless upgrade from zope2->zope3 and supporting
python-2.5. Yes, it causes problems, but I'm really not sure if things
would be better the other way.

Martin

> 
> Cheers
> 
> Joachim
> 
> 
-- 
Best Regards,
Martin Kudlvasr
Zope Portal Developer
---------------------------------------------------------------------
SUSE LINUX, s.r.o.                          e-mail: mkudlvasr@xxxxxxx
Lihovarská 1060/12                              tel: +420 284 028 966
190 00 Praha 9                                  fax: +420 284 028 951
Czech Republic                                    http://www.suse.cz/
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >