Mailinglist Archive: opensuse-buildservice (295 mails)

< Previous Next >
Re: [opensuse-buildservice] update-alternatives: No such file or directory
  • From: andreas.hanke@xxxxxxxxxxxxxx
  • Date: Fri, 02 Mar 2007 04:11:37 +0100
  • Message-id: <20070302031137.176850@xxxxxxx>
Hi,

> > If antlr is in BuildRequires and /usr/sbin/update-alternatives in the
> > Requires of antlr, shouldn't it work even without a direct
> > BuildRequires on update-alternatives?
>
> it would need to be a PreReq to work

It is actually a PreReq and a Requires(postun), which should work. No idea why it doesn't work.

It's still illogical that the package mixes PreReq and Requires(postun). For consistency reasons, it should either use the legacy PreReq or the new-style Requires(post)+Requires(postun) and not a mixture of both, but this cannot affect functionality.

Andreas Hanke
--
Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen!
Ideal für Modem und ISDN: http://www.gmx.net/de/go/smartsurfer
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >