Mailinglist Archive: opensuse-buildservice (257 mails)

< Previous Next >
[opensuse-buildservice] Building packages
  • From: Aaron Bockover <abockover@xxxxxxxxxx>
  • Date: Mon, 16 Oct 2006 19:11:47 -0400
  • Message-id: <1161040307.28363.30.camel@xxxxxxxxxxxxxxx>

I'm just getting into the build system, trying to set up Banshee. I have
the "Banshee" project set up, and first tried to migrate my
"libipoddevice" package from autobuild.

I first tried to build locally using osc:

osc build SLE_10 i586 libipoddevice.spec

This started pulling down (slowly) SLE packages, but failed here:

Error: No more mirrors to try.
Failed to retrieve libstdc++-4.1.0-28.4.i586.rpm from the following
locations (in order):

I then committed libipoddevice to the "Banshee" project and clicked
"Trigger Rebuild" in the web interface. It has been scheduled there for
almost 4 hours I think.

So my questions:

a) Any reason why libstdc++ can't be pulled down? (would be nice if this
were fixed)

b) Why is it taking 4 hours to start building libipoddevice in the build
service? What if it comes back failed after it's finally started to
build - do I have to wait another 4 hours for my second try? This seems
like an insane amount of time - and libipoddevice is a very simple
package to build. I'm worried that when I actually get to Banshee
itself, the process will take hours and hours and hours.

c) Maybe there's something else I should be doing altogether? I'm
completely new to the build service and am mostly just poking around,
although at the same time I would very seriously like to host Banshee's
builds inside the build service. I'm dead set on providing easy to use
and updated packages for Banshee for SUSE/SLED at the same time I
release my tarballs.

Thanks in advance for the insight and response.


Aaron Bockover

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >