Mailinglist Archive: opensuse-bugs (6588 mails)

< Previous Next >
[Bug 1143104] New: zypper in certbot will downgrade package
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 27 Jul 2019 09:32:10 +0000
  • Message-id: <bug-1143104-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1143104


Bug ID: 1143104
Summary: zypper in certbot will downgrade package
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 15.0
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Installation
Assignee: yast2-maintainers@xxxxxxx
Reporter: chris@xxxxxxxxxxxxxxxx
QA Contact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---

a `zypper in certbot` should install the `latest` available version of cerbot,
no matter if there is a certbot package or the newer python2-certbot and not
trying to downgrade ...

obviously missing or wrongly set "Obsoletes/Provides"

xxxxx-03:~ # zypper in certbot
Repository-Daten werden geladen...
Warnung: Repository 'openSUSE-Leap-15.0-Update-Non-Oss' scheint veraltet zu
sein. Ziehen Sie in Erwägung, eine andere Spiegelung oder einen anderen Server
zu verwenden.
Installierte Pakete werden gelesen...
Paketabhängigkeiten werden aufgelöst...

Problem: installiertes python2-certbot-0.30.2-lp150.6.1.noarch macht certbot <
0.30.2, welches durch certbot-0.24.0-lp150.1.4.noarch angeboten wird, obsolet
Lösung 1: Folgende Aktionen werden ausgeführt:
Deinstallation von python2-certbot-0.30.2-lp150.6.1.noarch
Deinstallation von python2-certbot-apache-0.30.2-lp150.2.1.noarch
Lösung 2: certbot-0.24.0-lp150.1.4.noarch nicht installieren

Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie (a)b [1/2/a]
(a):

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages