Mailinglist Archive: opensuse-bugs (6499 mails)

< Previous Next >
[Bug 1122614] armv7 efistub enablement missing in GRUB2
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 19 Jul 2019 12:37:42 +0000
  • Message-id: <bug-1122614-21960-jvA0Re59bB@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1122614
http://bugzilla.opensuse.org/show_bug.cgi?id=1122614#c39

Guillaume GARDET <guillaume.gardet@xxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Flags| |needinfo?(jlee@xxxxxxxx)

--- Comment #39 from Guillaume GARDET <guillaume.gardet@xxxxxxx> ---
(In reply to Michael Chang from comment #38)
(In reply to Guillaume GARDET from comment #37)
(In reply to Michael Chang from comment #36)
Hi Guillaume,

Could you please check if you seen the message "Please press 't' to show
the
boot menu on this console" and pressing the "t" could bring the menu or
not ?

No, the last message on serial is:
Welcome to GRUB!

Whereas with previous grub2.02, I also have the following lines after the
welcome message:
Waiting for Ethernet connection... done.
Please press 't' to show the boot menu on this console

Is /sys/firmware/efi present on your the system ? It is required to generate
the relevant message and hiddenentry in grub.cfg ..

[1]
https://build.opensuse.org/package/view_file/openSUSE:Factory/grub2/grub2-
SUSE-Add-the-t-hotkey.patch?expand=1

There is no /sys/firmware/efi/ as, IIUC, it would require grub2.04 to be
installed and when I install it, it still has grub2.02. And grub2.04 fails to
boot properly on RPi2 atm, as reported in #c5.
If I remove the EFI test condition, it is working fine. \o/

So, it leaves the broken boot of kernel, even with patched kernel for #c28

@jlee, did you or Chester made some progress and/or have something to test on
RPi2?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >