Mailinglist Archive: opensuse-bugs (6342 mails)

< Previous Next >
[Bug 1141052] New: build package doesn't have all necessary Requires:
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 10 Jul 2019 17:33:55 +0000
  • Message-id: <bug-1141052-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1141052


Bug ID: 1141052
Summary: build package doesn't have all necessary Requires:
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Hardware: x86-64
OS: Fedora
Status: NEW
Severity: Normal
Priority: P5 - None
Component: 3rd party software
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: brian@xxxxxxxxxxxxxxx
QA Contact: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Found By: ---
Blocker: ---

When I try to use "build" from
https://download.opensuse.org/repositories/openSUSE:Tools/Fedora_30/openSUSE:Tools.repo
I get errors about missing perl packages:

[ 0s] processing recipe /home/brian/daos/rpm/openpa/openpa.spec ...
[ 0s] init_buildsystem --configdir /usr/lib/build/configs --cachedir
/var/cache/build --repository
http://download.opensuse.org/distribution/leap/15.1/repo/oss/
/home/brian/daos/rpm/openpa/openpa.spec ...
[ 0s] initializing /var/tmp/build-root/.srcfiles.cache ...
[ 0s] /usr/lib/build/createrepomddeps --cachedir=/var/cache/build
http://download.opensuse.org/distribution/leap/15.1/repo/oss/
[ 1s] Can't locate XML/Parser.pm in @INC (you may need to install the
XML::Parser module) (@INC contains: /usr/lib/build /usr/local/lib64/perl5
/usr/local/share/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at
/usr/lib/build/Build/Rpmmd.pm line 27.
[ 1s] BEGIN failed--compilation aborted at /usr/lib/build/Build/Rpmmd.pm
line 27.
[ 1s] Compilation failed in require at /usr/lib/build/createrepomddeps line
32.
[ 1s] BEGIN failed--compilation aborted at /usr/lib/build/createrepomddeps
line 32.

And then:

[ 0s] processing recipe /home/brian/daos/rpm/openpa/openpa.spec ...
[ 0s] init_buildsystem --configdir /usr/lib/build/configs --cachedir
/var/cache/build --repository
http://download.opensuse.org/distribution/leap/15.1/repo/oss/
/home/brian/daos/rpm/openpa/openpa.spec ...
[ 0s] initializing /var/tmp/build-root/.srcfiles.cache ...
[ 0s] /usr/lib/build/createrepomddeps --cachedir=/var/cache/build
http://download.opensuse.org/distribution/leap/15.1/repo/oss/
[ 0s] Can't locate LWP/UserAgent.pm in @INC (you may need to install the
LWP::UserAgent module) (@INC contains: /usr/lib/build /usr/local/lib64/perl5
/usr/local/share/perl5 /usr/lib64/perl5/vendor_perl
/usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at
/usr/lib/build/download line 27.
[ 0s] BEGIN failed--compilation aborted at /usr/lib/build/download line 27.

These should be installed as Requires: dependencies in the build RPM. On
Fedora they are perl-XML-Parser and perl-libwww-perl.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages