Mailinglist Archive: opensuse-bugs (6499 mails)

< Previous Next >
[Bug 1140421] New: VUL-0: CVE-2019-5052: An exploitable integer overflow vulnerability exists when loading a PCX file in SDL2_image 2.0.4. A specially crafted file can cause an integer overflow, resulting in too little memory being allocated, which can lead t
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 04 Jul 2019 14:37:18 +0000
  • Message-id: <bug-1140421-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1140421


Bug ID: 1140421
Summary: VUL-0: CVE-2019-5052: An exploitable integer overflow
vulnerability exists when loading a PCX file in
SDL2_image 2.0.4. A specially crafted file can cause
an integer overflow, resulting in too little memory
being allocated, which can lead t
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 15.0
Hardware: Other
URL: https://smash.suse.de/issue/236311/
OS: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: Security
Assignee: lnussel+factory@xxxxxxx
Reporter: wolfgang.frisch@xxxxxxxx
QA Contact: security-team@xxxxxxx
Found By: Security Response Team
Blocker: ---

CVE-2019-5052

An exploitable integer overflow vulnerability exists when loading a PCX file in
SDL2_image 2.0.4. A specially crafted file can cause an integer overflow,
resulting in too little memory being allocated, which can lead to a buffer
overflow and potential code execution. An attacker can provide a specially
crafted image file to trigger this vulnerability.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-5052
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5052
https://talosintelligence.com/vulnerability_reports/TALOS-2019-0821

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
Follow Ups