Mailinglist Archive: opensuse-bugs (4794 mails)

< Previous Next >
[Bug 1050980] New: phpMyAdmin depends on deprecated/removed php mcrypt extension
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 27 Jul 2017 13:14:27 +0000
  • Message-id: <bug-1050980-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1050980


Bug ID: 1050980
Summary: phpMyAdmin depends on deprecated/removed php mcrypt
extension
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Upgrade Problems
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: jo@xxxxxxxxxxx
QA Contact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---

The phpMyAdmin package from here
<http://download.opensuse.org/repositories/server:/php:/applications/openSUSE_Leap_42.2/>
depends on php-mcrypt extension:

# zypper info --requires phpMyAdmin
Information for package phpMyAdmin:
-----------------------------------
Repository : Various php-applications
Name : phpMyAdmin
Version : 4.7.3-294.1
Arch : noarch
Vendor : obs://build.opensuse.org/server:php:applications

[...]

Requires : [16]
php-gettext
php-json
php-mbstring
php-mysql
php-gd
php-iconv
php-session
php-zlib
php-mcrypt
php-bz2
mod_php_any >= 5.5
/bin/sh
pwgen
sed
coreutils
grep

Most mcrypt functions have been marked deprecated in PHP5.5, the whole
extension in PHP7.0 and it has been removed in 7.1
The phpMyAdmin developers addressed this by favoring the OpenSSL extension over
mcrypt. Another issue with E_DEPRECATED notices were fixed in PMA 4.6.6
according to <https://github.com/phpmyadmin/phpmyadmin/issues/12800>

So PMA is no longer dependent on php-mcrypt. However, if someone installs
PHP7.1 on openSUSE, PMA will be removed.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >