Mailinglist Archive: opensuse-bugs (4652 mails)

< Previous Next >
[Bug 1044087] vagrant 'package' command results in backtrace: cannot load such file -- /usr/share/vagrant/lib/vagrant/action/general/package (LoadError)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 20 Jun 2017 07:41:55 +0000
  • Message-id: <bug-1044087-21960-vpKmdvL2kh@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1044087
http://bugzilla.suse.com/show_bug.cgi?id=1044087#c4

Markos Chandras <markos.chandras@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |robert.munteanu@xxxxxxxxx
Flags|needinfo?(markos.chandras@s |needinfo?(robert.munteanu@g
|use.com) |mail.com)

--- Comment #4 from Markos Chandras <markos.chandras@xxxxxxxx> ---
(In reply to Robert Munteanu from comment #3)
Can you try the version that is proposed as an update to 1.9.5?

https://build.opensuse.org/request/show/503978

Still doesn't work. Same problem

$ vagrant --version
Vagrant 1.9.5

...

/usr/share/vagrant/plugins/providers/virtualbox/action/package_setup_folders.rb:3:in
`require_relative': cannot load such file --
/usr/share/vagrant/lib/vagrant/action/general/package_setup_folders (LoadError)
from
/usr/share/vagrant/plugins/providers/virtualbox/action/package_setup_folders.rb:3:in
`<top (required)>'
from /usr/share/vagrant/plugins/providers/virtualbox/action.rb:157:in
`block (2 levels) in action_package'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/action/builtin/call.rb:47:in
`call'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/action/builtin/call.rb:47:in
`call'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/action/warden.rb:34:in
`call'
from
/usr/share/vagrant/plugins/providers/virtualbox/action/check_virtualbox.rb:17:in
`call'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/action/warden.rb:34:in
`call'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/action/builder.rb:116:in
`call'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/action/runner.rb:66:in
`block in run'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/util/busy.rb:19:in
`busy'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/action/runner.rb:66:in
`run'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/machine.rb:225:in
`action_raw'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/machine.rb:200:in
`block in action'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/environment.rb:533:in
`lock'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/machine.rb:186:in
`call'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/machine.rb:186:in
`action'
from /usr/share/vagrant/plugins/commands/package/command.rb:90:in
`package_vm'
from /usr/share/vagrant/plugins/commands/package/command.rb:70:in
`package_base'
from /usr/share/vagrant/plugins/commands/package/command.rb:43:in
`execute'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/cli.rb:42:in
`execute'
from
/usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/lib/vagrant/environment.rb:274:in
`cli'
from /usr/lib64/ruby/gems/2.2.0/gems/vagrant-1.9.5/bin/vagrant:122:in
`<top (required)>'
from /usr/bin/vagrant:23:in `load'
from /usr/bin/vagrant:23:in `<main>'


As I said on the first comment, it sounds like a file is missing because indeed
there is no /usr/share/vagrant/lib/vagrant/action/general/package_setup_folders
in the system and I don't see the new SR addressing anything in that area.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References